The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Need help with my Russian 91% (Kayfun Clone)

Discussion in 'Rebuildable Atomizer Systems' started by PowerofParanoia, Sep 13, 2014.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. PowerofParanoia

    PowerofParanoia Super Member ECF Veteran

    Sep 9, 2010
    San Marcos, TX
    So I managed to get my hands on a Russian 91%.

    It's my first RTA, but the coil building was simple for me because I used to do jewelry work.

    The problem I'm having is that the tank keeps leaking out of the airhole. I can't get it to keep a vacuum.

    I've checked every single o-ring and replaced them all, yet it still leaks terribly out of the airhole. I tried adjusting the airflow on it and that didn't work either. I can't seem to figure out the problem. I've been screwing with this thing for nearly 6 hours total over the past 3 days and can't get it to stop.

    Any thoughts?
     
  2. Gimpy1261

    Gimpy1261 Senior Member ECF Veteran

    Mar 6, 2012
    Ga. Down Under
    I had one doing the same thing. It might be over-filled. Mine was it turned out. I have the plastic window for mine, but I wa s trying to use it a ll meta l so I was having trouble knowing when to stop putting juice in it. Now I just squeeze the needle bottle 3 times call that full and on with the show.
     
  3. luke213

    luke213 Senior Member Verified Member ECF Veteran

    Mar 2, 2014
    Up
    Make sure the chimney is making a good seal with the top cap. Some of the clones are a touch short there and can cause issues. That said I've got one that is a trouble maker with the same issue that I can't figure out.

    Sent from my XT875 using Tapatalk
     
  4. Dshobe

    Dshobe Senior Member Verified Member ECF Veteran

    Feb 25, 2014
    Denver, CO
    If it isn't over filled, it could be a wicking issue. Can you describe your wick?
     
  5. kteto

    kteto Senior Member ECF Veteran

    Jun 10, 2013
    London
    It could be manufacturing defect..i got an old clone KF and it pee daily..my new clone KF do not have this problem..
     
  6. PowerofParanoia

    PowerofParanoia Super Member ECF Veteran

    Sep 9, 2010
    San Marcos, TX
    The chimney makes a really tight connection with the o-ring at the top, so I'm not sure it's that.
     
  7. PowerofParanoia

    PowerofParanoia Super Member ECF Veteran

    Sep 9, 2010
    San Marcos, TX
    I'm utilizing organic unbleached cotton, twisted it and ran it through the coil.
     
  8. PowerofParanoia

    PowerofParanoia Super Member ECF Veteran

    Sep 9, 2010
    San Marcos, TX
    It's hard to determine when it's overfilled. They advertise that it can hold 4.5 mils, but I only really fill it up halfway and it's still leaking.
     
  9. sunnata

    sunnata Super Member Verified Member ECF Veteran

    Oct 28, 2013
    voidness
    whats the distance from the coil to the airhole? if too close it could cause some leaking, but I doubt it would be as terrible as you described. pics of your build would greatly help folks with troubleshooting, please post some images if you can manage.

    hope you can get it sorted, g'luck
     
  10. kmapjr

    kmapjr Full Member

    Dec 8, 2013
    Detroit, Mi, USA
    My brother has had this same issue on a Tobeco clone, I replaced all seals & still was a flooder but my hCigars seem to not leak a drip & I build chimney coils & horizontal coils on those, I looked over & over on that thing worked on it with many builds but could never stop the leak.. Hope u find an answer, good luck to you!


    No It's Not Smoke
     
  11. XBarbarian

    XBarbarian Super Member Verified Member ECF Veteran

    Jul 13, 2014
    Largo, FL
    so.. I top fill my Russian.. it will leak a bit, I blow through the drip tip back into it, forces the juice out of the air hole, then its fine.

    coil height to the air hole can make a difference, all seals tight, etc. fill to about 1/4- 1/8 inch from the top. ( if you are top filling )

    try blowing back into it, cleaning it, then using it. see if it still leaks after that. if so, I suspect its defective,
     
  12. deryk

    deryk Senior Member Verified Member ECF Veteran

    I have been having the same problem with mine. Last night I built a micro coil with 1 piece of 2.5mm cotton wicking (yeah I need to buy some organic cotton balls, but I bought the wicking when I had my ProTank2) I used to use 2 pieces of the 2.5mm cotton wicking...hoping that it was just wicking up too much juice. So far so good...guess time will tell if it solved the problem. Best of Luck!
     
  13. captainchunk

    captainchunk Full Member

    Sep 5, 2014
    Tempe, AZ, USA
    I top-fill my authentic Russian 91%. For me, it's the only way it WON'T consistently leak. By top-filling, you're creating a new vacuum seal in the chamber each time you fill. It takes a few tries before you get it right, but once you do, you'll rarely experience leaks. There's a lot of video tutorials out there that show you how to do this.
     
  14. vapdivrr

    vapdivrr ECF Guru Verified Member ECF Veteran

    Jul 8, 2012
    sarasota,fl
    check the plastic tank near the threads. as others have mentioned it could be a variety of things but the only time i had a kayfun leak like this the plastic tank had a slight crack in it or the threads can be crossed. i have dropped my kayfun a time or two and it made the threads jump which made for a bad seal. so if you haven't found the issue these are just some other possibilitys
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice