The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Received iTaste SVD yesterday - already a problem less than 24 hours later :(

Discussion in 'VV/VW APV Discussion' started by just4747, Mar 31, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Fullknight

    Fullknight Ultra Member ECF Veteran

    Sep 1, 2012
    Oklahoma
    I bought 2 from fasttech no trouble with either one. Work perfect. I am careful with everything have never dropped,etc.
     
  2. Chas F.

    Chas F. Ultra Member ECF Veteran

    Sep 3, 2013
    Colorado
    Thanks Fullknight, I appreciate the response. I think I'm gonna post a new thread for recommendations ~$100.
     
  3. Andrea S

    Andrea S Full Member Verified Member

    Sep 12, 2013
    Rome, Italy
    I don't know, I was just replying to that article that seems to state fSVD are of a better quality than the other version. Or so I got by using the translator.

     
  4. Soulfly54

    Soulfly54 Full Member

    Mar 26, 2013
    Waukesha, WI
    I got mine at a dealer here in the U.S. So no- it's not only a FastTech problem. It's a cheap-... button design problem on Innokin's end.
     
  5. Biff_Whipster

    Biff_Whipster Full Member Verified Member

    Jun 19, 2013
    Austin


    I have been using and loving my SVD for close to 2 months and have had no issues with firing. I have tried 'screwing in' the button and cannot replicate the locking that you are describing. I agree with the others in assuming you just got a bum unit. I would get it replaced and enjoy. I love using my SVD in 18650 mode. It's a behemoth!

    Hope everything turns out okay for you!
     
  6. Pigeonaras

    Pigeonaras Full Member

    May 7, 2013
    Greece
    Good evening...
    My SVD fell down yesterday and "+" button doesn't work anymore... :(
    Probably it fell from the button side ...
    Now I cannot unlock the device and I have to vape at 14W (last setting...!!!!).
    Also I cannot check resistance... :(
    Does anyone know how to disassemby it to have a look at the board, because I think that I have to resolder the button ???
    I searched but I found nothing about SVD disassembling... :(
    Thank you.......
     
  7. jimbill

    jimbill Super Member Verified Member ECF Veteran

    Jan 4, 2011
    aurora,indiana
    Hello Pigeonaras all you need to do is get a pair of needle nose pliers and grip the little ring around the button and pop it off and check to see if the tack switch is stuck or it could be dirty this is the best stuff for tack switches and will clean it good and make it work like new.
    http://www.amazon.com/DeoxIT%C2%AE-D100-Spray-NSN-6850-01-435-6478-solution/dp/B0014F110I
     
  8. rangie

    rangie Senior Member Verified Member ECF Veteran

    Oct 22, 2013
    NOTTINGHAM ENGLAND
    all buttons spin you definitely have faulty svd get it sent back to the vendor I have never had a problem with mine mis fire getting stuck or any thing its a great mod I think you just got a bad one
     
  9. VaPreis

    VaPreis Ultra Member Verified Member ECF Veteran

    Oct 5, 2013
    St. Louis, MO
    I've had my SVD for a little over a month with no issues. It is a genuine Innokin.
     
  10. Steakjuice

    Steakjuice Senior Member ECF Veteran

    Aug 19, 2013
    Toronto, ON Canada
    My SVD randomly stopped working on me. I left it by my window Saturday night and it wouldn't turn on Sunday morning. The buttons still "work" because I am able to switch modes without a problem, but clicking the fire button or using the +/- buttons alone does nothing. It's not the battery, because when I put it in I see the display light up and everything, and I tried a fresh one to test. The fire button isn't stuck in any way, it still clicks, it just doesn't "do" anything. Haven't seen anyone report this issue before, so I'm confused! Maybe it's a connection issue, I'll try with another atty later tonight.

    Using my twist as a substitute, and it's just not the same.

    Update: Turns out my atty had some leakage. Cleaned the contacts thoroughly and I'm back in business. Crisis averted.

    Update 2: It won't turn on anymore. The king is dead. Chi-You clone on the way. It was good while it lasted.
     
  11. JX3P

    JX3P Full Member

    Aug 25, 2012
    Czech Republic
  12. TheVaporBear

    TheVaporBear Full Member Verified Member

    May 8, 2009
    Plymouth, MN
    Sorry to hear of your troubles :(
     
  13. VapieDan

    VapieDan Vaping Master Verified Member ECF Veteran

    I too have the problem of turning off on it's own. I see no button issue. Also changed out batteries, Clearomizers etc. which all work fine on other devices. I think there is a bug in the programming. Very Sad. Like it a lot but too annoying to use as is. Curse you Innokin.
     
  14. garyoa1

    garyoa1 Ultra Member Verified Member ECF Veteran

    Oddly, every once in a while I use mine, release the button and the green flashes maybe 10 times or so. Works, but weird. :/
     
  15. HighPlains

    HighPlains Full Member

    Dec 31, 2013
    Indianapolis
    The SVD is notorious for the defective fire button. I wish I had known this before buying it and now my SVD is useless. Innokin is aware of it but will not stand behind their product. It's too bad that the SVD has a faulty fire button made with a cheap, flimsy micro chip because it is an otherwise well-built product. Just google "SVD fire button" and there are hundreds of notices from buyers who paid good money for a paper weight.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice