The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Received iTaste SVD yesterday - already a problem less than 24 hours later :(

Discussion in 'VV/VW APV Discussion' started by just4747, Mar 31, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. just4747

    just4747 Account closed on request ECF Veteran

    Oct 6, 2008
    That's the same issue my first one had that this thread is about. It is truly not normal and twisting it should never tighten it down like that. Received my replacement one yesterday and I can spin it all day and it never gets tight. I would get a replacement like I did!
     
  2. NismoNinja

    NismoNinja Full Member

    Mar 11, 2013
    Phoenix
    I have an SVD and have had it for a couple of weeks now. It performs flawlessly for me. I did try rotating the firing button (mine is smoked plastic in color so the LCD lights shine through it). I was able to get the button to spin freely in both directions, but I never got it to stop or lock. I clicked it off and tried pressing the button like I was firing it and then twisting it, but still didn't get the button to tighten. I would really recommend sending it back as it sounds like you've got a connection that is not fitted properly and needs to be addressed by the manufacturer.
     
  3. OBF_Vapor

    OBF_Vapor Super Member Verified Member ECF Veteran

    I have a similar problem. I got mine two weeks ago from MVS and this weekend the button got all weird, shutting off on its own firing on its own, and sticking. The firing on its own freaked me out the most. Just sitting on my desk and the green light came on and I can hear my carto hissing. The bummer is MVS is in the middle of a move so who knows when i will get a reply to my email about the return.
     
  4. Xobeloot

    Xobeloot The Dirty Monkey Verified Member ECF Veteran

    May 29, 2013
    Grafenwöhr, Germany
    Mine is on it's way back to the vendor for this same issue.


    Sent from my iPhone using Tapatalk 2
     
  5. look30

    look30 Super Member Verified Member ECF Veteran

    Apr 10, 2013
    California
    It sounds like the hole for the button is too tight and is rubbing against the plastic of the button , I would put a few drops of silicone or soy oil around the button ,
    wait until it get's in and press the button to make sure it get's lubricated. Repeat every month and that should keep it working fine.
    Off course you can retunr it but then you have to pay for shipping and such so it's worth trying .
     
  6. Faylool

    Faylool Ultra Member Verified Member ECF Veteran

    Mine had firing issues and it's the carto. So basically on mine it's got the pin set a hair of a mm too low or something like that. I'm not happy about it but it's not worth exchanging because different cartos fit differently and all it takes is an extremely minor distance.
     
  7. Thunderball

    Thunderball Vaping Master Verified Member ECF Veteran

    May 5, 2013
    Grayson, Georgia
    No problems with mine (FT) Sorry some of you had problems
     
  8. spiderman

    spiderman Senior Member ECF Veteran

    Yes, My svd fire button has the same problem..when you press it down and spin either way it gets locked up and keep firing away...so I just maintain it at the "neutral" position that way it has no problems..aint sending it back for repair..not worth it...Thanks to this thread it helped me...I thought my svd got screwed after 14 days...but after reading this thread i tried spinning it back...and yes...the button came loose and the clickyness came back....thanks again and I will try the silicone oil thing to see if it works or not....Lucky did not throw away the svd before i read this thread...thanks all...
     
  9. MHTSOS

    MHTSOS Full Member Verified Member

    Jul 14, 2010
    California
    Just checked mine. It didn't get stuck but boy is it tighter. In other words it fees like it has very little travel and the clicky sound is completely gone.
    Mind you this is my original SVD which isn't from fasttech. My fasttech ones are built different to this (not as well in my opinion) and they don't do it at all.

    edit: Okay played with it for about two minutes and it was so touchy that I played with it til I got it back to where it was. Back to it's clicky self. With some rotation it seems to have an instant activation with no sound. I like it but it worries me so click click it is.
     
  10. MrSelf Destruct

    MrSelf Destruct Super Member Verified Member ECF Veteran

    Feb 2, 2013
    Cobra Island
    I have tried to do this to mine as well. Mine does not tighten up...just keeps spinning no matter which way you turn it.
     
  11. wanttoknow1

    wanttoknow1 Senior Member Verified Member ECF Veteran

    Jan 4, 2013
    Retired in Mexico
    Got mine worked fine for 2 weeks then one night it did the same thing button down no return tried the turning and does not chance still stays down. I will attempt to return it. Seems to turn freely so don't think plastic and s.s. ring are the problem.
     
  12. GetVaked

    GetVaked Super Member Verified Member ECF Veteran

    May 26, 2011
    Wisconsin
    They are 40 bucks and have a garbage switch/button. Bound to happen sadly.
     
  13. Gobra

    Gobra Senior Member ECF Veteran

    Aug 25, 2013
    Romania
    yes we have the same problem
    seller of us contacted innokin factory
    and innokin assumes no issue with button
    :mad:
     
  14. damthisisfun

    damthisisfun Ultra Member ECF Veteran

    Aug 6, 2012
    Katy, TX
    Got mine from FT -yes the click is gone - doesn't tighten when I rotate it - time to return -after a lot of thinking - I am gonna get me a Provari - yes it is expensive - but I am tired of the vamo v3 and svd both having issues....
     
  15. Gobra

    Gobra Senior Member ECF Veteran

    Aug 25, 2013
    Romania
  16. jackson32503

    jackson32503 Full Member

    Please let me know how this exchange panned out. I have the same mod & am having similar issues w/ fire button. Unfortunately, mine is about 6 weeks in, hence no longer returnable.

    Cleaning w/ rubbing alcohol seems to have helped a bit...along with a lot of playing with the button. I do find that when the button is rotated to either extreme, the problem is MUCH worse.

    Trying to iron it out. Otherwise, I'm quite happy w/ the mod...but this is a problem w/ THE essential function.
     
  17. jimbill

    jimbill Super Member Verified Member ECF Veteran

    Jan 4, 2011
    aurora,indiana
    My fire button broke a while back and i think that innokin should recall all the svd's it will only be a matter of time before those cheap little tack switch's fail.
     
  18. Soulfly54

    Soulfly54 Full Member

    Mar 26, 2013
    Waukesha, WI
    Had my SVD for about a month & a half & the firing button got stuck halfway down. Now I barely hover my thumb over it & it fires. Definitely turned me off to any other Innokin products.
     
  19. Andrea S

    Andrea S Full Member Verified Member

    Sep 12, 2013
    Rome, Italy
    Sorry to hear so many people having problems with their SVD.
    Mine works just fine, but I didn't get it from fasttech.
     
  20. Chas F.

    Chas F. Ultra Member ECF Veteran

    Sep 3, 2013
    Colorado
    Are all of the reported problems with SVDs purchased from FastTech? I'm about to pull the trigger on one and don't want to buy something that's gonna crap out on me.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice