The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Vaporesso "Short Atomizer" Fix

Discussion in 'New Members Forum' started by hamsway22, Aug 12, 2018.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. hamsway22

    hamsway22 New Member

    Aug 12, 2018
    Had to make this account and try to help people out because there was not a good solution for this I could find online currently. I had this problem shortly after getting my Vaporesso Revenger mini mod. After reading similar problems online, I tried cleaning all threads in the tank and coil and reassembling. I also read that a lot of people were saying make sure everything isn't screwed too tightly. I even called the shop i got it from and the dude just said it was a faulty coil. All wrong. What fixed it for me (and hasn't happened since) was making sure the tank was screwed into the mod tight enough (just slightly passed the natural tension). You can tell when it's tight enough because the resistance will read close to what your specific coil resistance is supposed to be. This most commonly happens when switching to new coils or removing the tank for anything. Good luck.
     
    • Like Like x 1
    • Informative Informative x 1
  2. BrotherBob

    BrotherBob ECF Guru ECF Veteran

    Dec 24, 2014
    Sunnyvale,CA,USA
    Welcome and glad you joined.
    Well said, I find this true on just about all types of Atty's (esp. RDA's).
     
    • Agree Agree x 2
    • Like Like x 1
  3. tara81

    tara81 Super Member ECF Veteran

    Mar 13, 2014
    canada
    No atomizer happens often with my vaporesso tarot nano and veco tank, thanks for the tip!
     
    • Like Like x 1
  4. MJCSD

    MJCSD Ultra Member ECF Veteran

    May 7, 2014
    usa
    Hello and welcome to ecf
     
    • Like Like x 1
  5. uthinkofsomething

    uthinkofsomething Super Member ECF Veteran

    Jun 7, 2015
    Toledo, Ohio
    Might it be that the mod or the tank have an inappropriate sized or spaced 510 pin? Maybe one pushes the other in and then it doesn't go back all the way?
     
    • Agree Agree x 2
  6. E30M42

    E30M42 Full Member

    Feb 19, 2015
    Norfolk va
    clean with rubbing alcohol
     
    • Like Like x 1
  7. stols001

    stols001 Mistress of the Dark Nicotinic Arts Verified Member ECF Veteran

    Supporting member
    May 30, 2017
    Tucson, AZ
    While I'm glad you found "your fix" I must say that the reasons for atomizer short can be many and varied although most certainly not having the pin screwed in all the way is going to cause a problem, most likely, but I suspect that is not the solution to each and every atomizer short that happens, although I'm glad you have found your fix, which is making sure the pin is making contact with the mod, which pretty much HAS to happen and the rest are also various sorts of means to make sure that connection is not being blocked.

    Slightly tighter than "loose" would be my overall recommendation although I have to say I have never had this issue with any Vapresso stuff, although to be fair, my "loose" might be another person's "very tightly" and whatnot, just glad it's working for you and welcome to ECF.

    Anna
     
    • Agree Agree x 1

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice