The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Wrong firmware

Discussion in 'Geekvape' started by Philipp Helbig, Oct 30, 2019.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Philipp Helbig

    Philipp Helbig New Member

    Oct 30, 2019
    Hey guys,
    I know that its really dumb no need to tell me -,-, but as i got my Aegis X i accidently tried to install the Aegis Legend firmware. Now its bricked and i already wrote the Geekvape support but i didnt got a reply till now. However I tried to reinstall the firmware via the google drive link and it should work, but to install a new firmware you need to have a firmware installed, in short it doesnt work. I need the original software with a compatible installer. Is there one out yet or does Geekvape give those things out and is it possible if not to get it rewritten by Geekvape?

    Greetings Philipp
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice