The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

ce4's on ultramax?

Discussion in 'Innovapor' started by riccohou, Jul 22, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. riccohou

    riccohou Full Member Verified Member

    Jul 22, 2012
    Houston
    i recently picked up some v2's and v3's and a 510 to 510 adapter and i cant get them to fire on the ultramax. although the adapter works fine on my AVA atty and the adapter plus the v2 works fine on my ego. anyone try this yet?
     
  2. ComfyChair

    ComfyChair Full Member

    Apr 17, 2012
    Huntsville, Al
    Mine was a bit fiddly at first. Only 1 of my 3 510 to 510 adapters worked with anything when I first tried them out. The only difference in the 3 is that the one that worked had a slightly protruding center post in the base while the non-working 2 had slightly recessed center posts. I pulled the switch assembly out of the cone, pushed the o-ring all the way down in the cone, then put the switch back in...it seems to have solved the problems with the other 2 adapters. Not exactly sure why but now all 3 adapters work with whatever I put on them. Not sure if this will help or not but thought I'd mention it since I had similar problems with mine.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice