The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

issue with MVP2

Discussion in 'Innokin Technology' started by Kswan, Sep 23, 2017.

Tags:
Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Kswan

    Kswan New Member

    Sep 23, 2017
    Spring, TX USA
    My MVP2 has now started to not be able to thread my tanks (kanger protanks 1 and 2) onto it (like the threaded part has stretched out) and the tanks now just slip into it and will not stay secured (my tanks work on all my other mods Kamry 20 and K1000) with no problems, and am curious as to what I can do to remedy the problem?


    Thanks in advance
     
  2. Shawn Hoefer

    Shawn Hoefer ECF Guru Verified Member ECF Veteran

    Supporting member
    Jan 21, 2015
    Arkansas Ozarks
    Early mods used chromed brass eGo/510 connectors. Unfortunately, once they're gone, they're gone (unless you want to disassemble, desolder, replace, solder...). For future reference, using an adapter that stays on the mod can significantly extend the life of the mod...

    $2.27 (Free Shipping) Iwodevape 510 Heat Dissipation Heat Sink for Atomizers (27mm, SS, SS Color) at m.FastTech.com

    Not that one, specifically... you'd want to match the size of the atomizer.

    Since the MVP2 (should you consider getting an identical/similar replacement unit) uses eGo threading, you'll also likely want a beauty ring under the heat sink.

    Sent from my SAMSUNG-SM-N910A using Tapatalk
     
    • Like Like x 1
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice