The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

T Priv Not Coming On

Discussion in 'New Members Forum' started by Mermaid26, Oct 12, 2018.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Mermaid26

    Mermaid26 New Member

    Oct 12, 2018
    So last night I put my T Priv to charge which it did but it refuses to come on but when you plug it in via USB it is charging. I already tried updating the firmware which didn't help.
    Can anyone give any advice on how to fix this?
     
    • Optimistic Optimistic x 1
  2. Baditude

    Baditude ECF Guru ECF Veteran

    Apr 8, 2012
    Ridgeway, Ohio
    Is there any way to determine the amount of charge your batteries have? My understanding is the T-Priv uses 2 external batteries. Are you using an external charger or charging with the USB port?

    What batteries (make and model) are you using? How long have you been using them? What wattage setting have you been using?

    May be silly to ask, but have you tried turning the mod on with 5 rapid clicks?
     
    • Agree Agree x 2
    • Useful Useful x 1
  3. rosesense

    rosesense ECF Guru Verified Member ECF Veteran

    Jan 1, 2010
    South GA
    What Bad said....the T Priv is finicky about turning on/off. You have to click really fast in case you haven't tried that. I have trouble clicking fast enough to turn it back on after I take the batteries out.
     
    • Useful Useful x 2
    • Informative Informative x 1
  4. Diver9543

    Diver9543 Ultra Member ECF Veteran

    Feb 26, 2015
    Oklahoma City, OK, USA
    I am not familiar with your mod or tank so I can't help you with your current problem. However, one thing I can do is say Hi and welcome to the forum. I'm sure others will be along soon with more knowledge about your gear.
     
    • Like Like x 1
  5. bombastinator

    bombastinator Vaping Master Verified Member ECF Veteran

    Sep 12, 2010
    MN USA
    I think you mean “activating”. Attempting to come on to your t-price is doomed to failure. :lol:

    Welcome to the forum btw :)
     
    • Funny Funny x 2
  6. VapePro

    VapePro Senior Member

    Sep 25, 2018
    You might have to take off the firing arm and clear out the juice inside the fire button switch.
     
    • Useful Useful x 1
  7. BrotherBob

    BrotherBob ECF Guru ECF Veteran

    Dec 24, 2014
    Sunnyvale,CA,USA
    Welcome and glad you joined.
    Might try firing with fully charged new off the shelf batteries. Old batteries may cause this problem.
    Could contact:
    Local B&M Vape Shop (Phone first then visit)/someone who knows what their doing -----Might be simple.
    Vendor who sold it ---see if they will advise (any authorized distributor).
    Manufacturer contact ---see if they will advise.
     
    • Useful Useful x 1

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice