The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Vamo v4 keeps displaying "SHORT" - how do I fix it??

Discussion in 'VV/VW APV Discussion' started by molliePOP, May 21, 2015.

Tags:
Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. molliePOP

    molliePOP Full Member

    Don't know if this is the right thread...

    I've had this Vamo v4 for 3 months and it's been great until yesterday. It says "short" on the display.

    I have tried several different coils, I have cleaned it really well. Is the pin not touching, or do I need to reset it somehow?

    It will give me 2 or 3 vapes and then say short until I try a new coil, then it does it again.

    HELP! I am stuck with an ego twist until I can fix this problem!

    Thank you for any ideas.
     
  2. DavidOck

    DavidOck ECF Guru ECF Veteran

    Supporting member
    Pin not touching, the message would be along the lines of "no atomizer" or "9.9", not short. Take your topper off and press/hold the plus button to see.

    What topper and what resistance coil? Could be that all your coils are just too low a value for the Vamo.

    Or it could be that you've overtightened one too many times, crushing the insulator between the Vamo center pin and the base, so when you put your topper back on, it gets forced down and touches, causing the short. Again, but with the topper on, press and hold the plus button to see what it's seeing as the resistance. Probably anything lower than about 1.2 Ω won't work on the Vamo.

    If it IS a crushed pin insulator, you can try to wiggle it back up. Take the battery out. Use a small stiff poker - straightened paper clip or similar - and walk it around the pin nudging the pin up from several points around it. If that's the problem, working it up 1 mm is probably all that's needed.
     
  3. twgbonehead

    twgbonehead Vaping Master ECF Veteran

    Apr 28, 2011
    MA, USA
    Try loosening the head ever so slightly and see if the problem goes away. If so, David's suggestion is probably right on the money.
     
  4. Ronald3638

    Ronald3638 Super Member ECF Veteran

    Aug 16, 2013
    Zeeland, MI, USA
    At some point you may have to replace the insulator. There are several videos on how to do this using a Danco number 60 O-Ring. I had to do this with my Version 2 Vamo and it worked great.
     
  5. Robino1

    Robino1 Resting in Peace ECF Veteran

  6. evan le'garde

    evan le'garde Vaping Master ECF Veteran

    Apr 3, 2013
    Had this the day i bought it. The insulator had popped out as soon as i screwed on an atty. Replaced the insulator with something better. Had to pull the entire pin out along with the cable it was attatched to then slide another insulator onto it. The insulator it comes with simply isn't any good, it's far too loose to be fit for purpose.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice