The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

JUUL issues (cannot draw, charges fine)

Discussion in 'Vape Pod Systems' started by Oliver Alvarez, Mar 25, 2017.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Oliver Alvarez

    Oliver Alvarez New Member

    Mar 25, 2017
    Hello, my JUUL is charging and tells me the power when I double tap just fine. When I draw, however, no light comes on, and I get no airflow. Pods work just fine in all my friends' JUULs, but mine doesn't recognize any kind of inhale. Any advice?
     
  2. Lessifer

    Lessifer Vaping Master Verified Member ECF Veteran

    Not sure why you posted this in Media and General News, but if there is an air activated switch in the juul, the airway is probably blocked by something. Did it have a leak at some point?
     
  3. Oliver Alvarez

    Oliver Alvarez New Member

    Mar 25, 2017
    Sorry, this is my first post. No major leaking issues, I've only been using it for a few months.
     
  4. Lessifer

    Lessifer Vaping Master Verified Member ECF Veteran

    no worries, the thread will likely get moved to the appropriate place, the mods are good about that.

    I don't have a juul but see if you can tell where the airflow is supposed to be on the battery part, and see if you can try to blow through it. It's likely clogged but I have no idea if there's a way to clear it.
     
  5. classwife

    classwife Admin Admin Verified Member ECF Veteran

    Supporting member
    ...correct thing to do is to Report the thread and ask for it to be moved :)

    But, I stumbled on this so I will move it to Pod Systems
     
    • Like Like x 1
  6. Lessifer

    Lessifer Vaping Master Verified Member ECF Veteran

    sorry, wasn't sure if Report was the correct action.
     
  7. DawnBella

    DawnBella Super Member ECF Veteran

    Jul 22, 2011
    USA
    You're not making a solid connection perhaps but I've had this happen with more than 1 JUUL battery. Not a fan. Try another pod and also trying standing battery upright and tapping the bottom to make sure the connection part (4 gold pins) didn't slip out some. If not, the battery went bad.

    Ps. If you wanted to take battery apart, safely push down on pins inside battery that pod touches and slide out unit from bottom. I've done this when flooded with liquid.

    Good luck!! Yet another reason why I don't use JUUL anymore. Battery always goes bad and $50+ for yet another kit.
     
    • Like Like x 1
  8. Thenhanian

    Thenhanian New Member

    May 30, 2017
    Well one option is, is if you have warranty on it then you can just send it back for a new one. Before you do that, the rubber inside on top of the 2 gold things, may be slightly above it. Preventing the pods coming in contact with it which produces vapor.

    To fix it take a paper clip and just push the bottom up and put the same way as the cleaning method. When this is done make sure the rubber is on properly and push it back down MAKING SURE ALL CORNERS OF THE RUBBER ARE EQUAL AS IT GOES BACK IN. You will know how far to push it back when the light is lined up. Connect your pod and see if the light flashes for a second. If it does, your in good shape. The last thing now is to draw and if this is good your done! If not contact juul support, or use your 1 year warranty.

    Hope this helps, peace
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice