The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Quick fix for SMOK Alien ohm inaccuracy

Discussion in 'APV and Mods Discussion' started by lobeezy, Jun 30, 2017.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. lobeezy

    lobeezy New Member

    Jun 11, 2017
    I just posted this to Reddit, but i thought I'd share it here as well.

    This is a quick fix for the SMOK Alien reading inaccurate and fluctuating ohms. If this has been posted before, I apologize. While I found many, many posts on numerous forums outlining this problem, I couldn't find a single post anywhere detailing/ outlining an exact possible fix for it and thought I'd share my solution. So here we go:

    You will need- 1 T6 Torx screwdriver and a little bit of common sense. :)

    • The problem: Alien mod reading wildly inaccurate ohms with fluctuating amounts no matter what tank/ coil you use.
    After screwing on a tank or RDA and clicking the fire button, my SMOK mod would proceed to read the wrong ohms on the coil(s) installed. Example: The Alien would read anywhere between .45 to 1.5(!) ohms on a .40 Q2 baby beast coil, and between .24 and 1.8(!!) ohms on a .2 dual coil build in my RDA. No amount of unscrewing and re-screwing the tanks/RDAs on my mod would get coils to read right. (If you're having this problem, you know what a pain it is!) I verified all coils I had this problem with myself on an ohm reader and various other mods to make sure that the Alien was indeed not reading them correctly. And by 'all coils I had this problem with', I actually mean every single coil I tried. It wasn't reading anything correctly.

    • The solution: After unscrewing and removing the four Torx screws on the top of my Alien and removing the top cover, I saw that the 510 pin had come off center of the spring it sits on top of. Because it was off center, the 510 pin was much lower than it should've been and was also leaning at an angle. Reseating the pin onto the middle of the spring and making sure it was level, I screwed the top back on and presto, my Alien was reading accurately! It took all of 5 minutes and is definitely worth a shot if your Alien has the same issues mine had.

    • Detailed procedure:
    Remove tank and batteries from mod.

    Remove the four Torx screws from the top of the mod. [​IMG]

    Gently lift the top cover off of the mod. I say gently because there is a thick black wire attached to the 510 screw threads. Just keep the cover attached to the wire but move it out of the way so you can reach the pin. [​IMG]

    Gently readjust the 510 pin so it is directly on top of and in the middle of the spring it sits on top of. I say gently because there is a thick white wire attached to the pin. I only had to fiddle with mine for a few seconds to get in into the correct position. There are three clips on the bottom of the pin that catch on the spring when it is placed correctly. [​IMG]

    Replace the top cover and screw it back on and you're done! [​IMG]

    This quick fix worked for me, and for those with the same maddening problem I had, I hope it works for you as well! Thank you and enjoy!
     
    • Like Like x 12
    • Winner Winner x 1
  2. lobeezy

    lobeezy New Member

    Jun 11, 2017
    I'm sorry, give me a few and I'll post some pics...
     
    • Like Like x 1
  3. Skold

    Skold Ultra Member ECF Veteran

    Jan 24, 2016
    My first alien did this but my current version b one is fine, think it was fixed in the later models but this info is great thanks for the post!
     
    • Like Like x 1
  4. cashrc

    cashrc Full Member

    Feb 10, 2015
    Texas
    Just did this to mine, its a lot better. Still reads my Sense Blazer .2 coils off, but on the mark on the .6 Ceramics and my other tanks. Thanks for posting this.
    Cash
     
    • Like Like x 2
  5. MaxximusRevelation

    MaxximusRevelation Senior Member ECF Veteran

    Jul 12, 2016
    I had incorrect ohm readings constantly on my Xcube. Good to see after a long year and making a thousand new mods that they address the issues that should be addressed...... Oh wait wrong thread:lol::D
     
    • Like Like x 3
  6. Lady M

    Lady M Super Member ECF Veteran

    Jan 19, 2011
    Oregon
    I bet this tip is going to help a whole lot of people, thanks for caring for the Alien owners.......

    Sent from my LG-V930 using Tapatalk
     
    • Like Like x 2
  7. bigbob2322

    bigbob2322 Vaping Master Verified Member ECF Veteran

    Jul 27, 2014
    Schiller PK IL USA
    Nice tip buddy and thanks.
     
  8. Skold

    Skold Ultra Member ECF Veteran

    Jan 24, 2016
    That's not good, got an Xcube ultra today & the damn thing misfires :( not even had it a day!
     
  9. stols001

    stols001 Mistress of the Dark Nicotinic Arts Verified Member ECF Veteran

    Supporting member
    May 30, 2017
    Tucson, AZ
    Thanks for posting that here, a lot of people are going to thank you, I think :)

    Anna
     
    • Like Like x 1
  10. pfaber11

    pfaber11 Ultra Member ECF Veteran

    Dec 16, 2009
    england
    I've got a first addition Alien with no problems at the moment but will remember this fix just in case. Thank you for sharing. Vape on .
     
  11. NickMcCormack

    NickMcCormack Full Member

    Jul 11, 2017
    Bradford, England
    Hi sorry if you already sorted this but the misfire is usually sorted out by updating the firmware, the stockfirmware is pretty naff on most of the SMOK devices. I had the same issue when I got my alien the other day. I called up SMOKtech and they basically took me through the update process. One thing I will say though is they put the scare tactics on you. when going through the process they tell you at every stage that if you do anything wrong you WILL brick your MOD. Once with firmware was updated everything is more responsive and generally the thing functions a whole lote better. thanks.
     
  12. DaveP

    DaveP PV Master & Musician ECF Veteran

    Supporting member
    May 22, 2010
    Central GA
    • Like Like x 2
  13. Skold

    Skold Ultra Member ECF Veteran

    Jan 24, 2016
    I find the pico really inaccurate. My 1.8 coil reads at 1.9
     
    • Like Like x 2
  14. Skold

    Skold Ultra Member ECF Veteran

    Jan 24, 2016
    I find the pico really inaccurate. My 1.8 coil reads at 1.9
     
  15. Skold

    Skold Ultra Member ECF Veteran

    Jan 24, 2016
    Double post my phone is playing up
     
  16. XRec C

    XRec C Senior Member

    Jul 12, 2017
    Florida
    Question....I dropped my Alien the other day and since then I noticed the connection is slightly raised now. A couple of days later after a coil build I screwed my griffin back on and it kept saying no coil. I tried a subtank and it read it fine so I inspected the griffin and it's fine although it is the tank I was using when I dropped it. Upon closer inspection I can see that the center pin in the alien is off center now and to make it work with my Griffin I have to screw it on the kinda shove the tank down on the mod hard. Do you think Ur fix would correct this and is there a way to fix the connection being raise up out of the mod a little? It's too late tonight but guess I'm gonna give it a shot tomorrow. Any advise would be appreciated...
     
  17. lobeezy

    lobeezy New Member

    Jun 11, 2017
    I'm almost positive it would fix it. You said it's off-center; once you remove the top of the mod, you will be able to see just how much off center and adjust accordingly.

    The spring is conical; The diameter of the spring gets smaller from the wider top (where the 510 sits) to the narrower bottom. The only thing holding the spring and keeping it centered (besides the 510 when the top is on) is a small plastic nub that the bottom of the spring sits on and fits on to (think legos). A drop could easily knock things out of position considering they're not securely attached to anything to begin with. That being said, it's easy to get everything in line again. I'll update this weekend to show the spring/510 assembly in more detail.

    Feel free to ask if you have any issues and I'll do my best to help. :)
     
    • Like Like x 1
  18. Bayou14

    Bayou14 Full Member

    Feb 22, 2015
    Bush, LA
    Thank you. Just ordered an Alien, so I bookmarked this post.
     
    • Like Like x 1
  19. Hi! First time posting here. I am having the same problem with my Alien. Tried the fix but it didn't
    make much of a difference. One thing i did notice,which I think is part of the problem is the white
    wire that attaches to the 510 pin. The wire is very short and runs just under the edge of the pin not allowing the pin to travel up and down on the spring as it should. I've also tried to do a firmware update
    on mine with no success. I keep getting error messages and from what I have read others have had
    the same problem trying to update from v1.2.1.
     
  20. ThermicOhm

    ThermicOhm New Member

    Dec 23, 2017
    Thanks for posting this I am having the same issue but after removing the top connector housing section I came to find it is not really movable, perhaps I have the second Rev model. What seems to fix this for me however is tightening the tank down just until it makes connection then pulling up. If I tighten any more than that I get 2.4+ ohm readings on .12 -T10 coils. I put a little paper spacer between the mod and tank but tightening to the spacer nets the same result. Like the weight of the coil pushes down on the embedded 510 Connect.
     
    • Like Like x 1
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice