The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

I'm having issues with the UWell Crown II, and it's not good.

Discussion in 'Sub-Ohm' started by Warjec, Jul 27, 2016.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. ajb314

    ajb314 New Member

    Sep 6, 2009
    I just got a crown 2 tank today came with wrong v2 coils. I went back to the shop and they gave me the version 3 coils. 2 yellow bands on it I called uwell yes those are the newest ones...
     
  2. herb

    herb Vaping Master ECF Veteran

    I got a Crown II and it came with the yellow band coils and it's fantastic , outstanding airflow , never ever leaked a drop and the Rafale RBA works fantastic on it also . Coils last over 3 weeks of heavy vaping , i'm shocked at how good they are actually .

    The clones of these tanks can fool just about anybody , very tough to tell between them , some have said they believe certain vendors may not be aware if they are selling clones or authentics .

    I don't know anymore than that though .

    Packaging etc.. looks identical .
     
  3. Cheallaigh

    Cheallaigh Ultra Member

    Aug 13, 2016
    Georgian Bay, Ontario
    you know, sometimes the clones are an improvement
     
  4. Spike672

    Spike672 New Member

    Oct 17, 2016
    When using an RDA it's recommended that you remove the outer fibrous layer of the cotton to aid wicking. Take a sewing needle and scratch or "fluff" the cotton in the juice feed holes. Hey presto wicks like a pro much improved. I was struggling to vape at 30 watts. After the seeing needle trick 50 watts+ is no problem. Hope this helps, at least till UWELL gets its act together.
     
  5. daniele25

    daniele25 Ultra Member Verified Member ECF Veteran

    Feb 18, 2012
    phoenix
    I've been using the original Crown tank for some time and absolutely love it (as far as flavor & vapor are concerned). Over time I started having the issue that some others have had where I would unscrew the top cap to refill it would disassemble the entire tank. As a result, I recently picked up the Crown 2, since that was one of the changes they made to solve that issue in the tank design. I made it a point to get the V3 coils (both yellow o rings), and I am still having the dry nasty hit issue. I'm seeing no difference than I did with the original .5 coil that came with the tank (one yellow, and one black o ring). I'm barely getting 24 hours out of any of them. I've been running at around 58 watts. Based on this thread I decided to give it one more try and stay at 50 watts and see what happens. But i am curious, is anyone else having these issues with the new coils with the 2 yellow o rings? (I was told those are the newest ones). Any insight is appreciated, as I really love the tank and I do love the flavor and performance initially, but then it all goes to crap within a day. (I've also tried poking holes as others have mentioned....works great right afterwards, and then back to nasty dry hits shortly afterwards). Would love to hear any insight on the "new" coils if anyone happens to have any. Thanks!
     
  6. Neonspeed

    Neonspeed Senior Member

    Jul 31, 2016
    I was having the same issue with the new coils, I think it's a vacuum issue with the tank and not so much the coils


    Sent from my iPhone using Tapatalk
     
  7. daniele25

    daniele25 Ultra Member Verified Member ECF Veteran

    Feb 18, 2012
    phoenix
    Thanks. It's definitely a bummer. Just seems so odd how it works great initially, and then goes downhill.

    Looks like I'm sticking to the orignal Crown and will just deal with the annoying top cap disassembling the tank issue. I may start a seperate thread on this, but does anyone have any experience with the Tobeco Super Tank or Super Tank Mini and how it compares to the Crown? They were pushing it pretty hard in a local vape shop recently.
     
  8. Herrick

    Herrick Super Member ECF Veteran

    Oct 21, 2016
    I was watching a video by Quest4Vape (I think that's his name) and he was saying the coils are perfectly fine at wattages lower than ones printed on the coils. I'm disappointed that Uwell hasn't even updated the pictures on their own website. At the very least they should make a note about it on their website.
     
    • Like Like x 1
  9. Bellarica1983

    Bellarica1983 New Member

    Apr 23, 2017
    I had the same problem... Barely hitting and tasting burnt at the same time after first day of use... After reading this thread I adjusted my wattage accordingly. Using uwell crown 2, .5 ohm, using ss temp contol, changed v wattage from 60 to 40... Working like a charm again....Thank you Jesus!
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice