The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Ego Twist broken button help.

Discussion in 'eGo Type Models' started by Th3 FaT 0n3, Jun 18, 2012.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Th3 FaT 0n3

    Th3 FaT 0n3 Senior Member ECF Veteran

    Nov 25, 2009
    Around
    I have an ego twist 650mah and i recently had it drop out of my pocket and the button got stuck in. Does anyone know how to fix one of these?

    2012-06-17 16.15.59.jpg

    Ive tried prying it with and exacto knife and just pulling it like a caveman. nothing works.
     
    • Like Like x 1
  2. martinc

    martinc Vaping Master Verified Member ECF Veteran

    Dec 12, 2011
    Montreal,Quebec,Canada
    You dropped it on its head?

    Looks like its got pushed in,making the whole switch assembly go down a mil or 2,prying the mechanism...just a guess though.

    Its firing all the time?

    I`d just buy another one.
     
  3. Th3 FaT 0n3

    Th3 FaT 0n3 Senior Member ECF Veteran

    Nov 25, 2009
    Around
    did buy another one but i really would like to fix this one. one can never have enough working batteries. as far as firing goes, before it ran out of charge, it was not firing the whole time only when i pushed the bottom in.
     
    • Like Like x 1
  4. icanbreatheagain

    icanbreatheagain Senior Member Verified Member ECF Veteran

    May 5, 2012
    strong island, ny
  5. CappyCanuck

    CappyCanuck Full Member

    May 26, 2012
    Burnaby, Canada
    Same thing happened to mine after a drop judging by the picture. Could never get the button to pop back out properly. However, after pushing on it for some and having to pry the button back out with my nail each hit, it finally got looser and would stop getting stuck. While the button is still not centered properly or coming out as far, it's perfectly useable now. Not sure how similar the damage is but that's what happened with mine.
     
  6. Th3 FaT 0n3

    Th3 FaT 0n3 Senior Member ECF Veteran

    Nov 25, 2009
    Around
    Mine is stuck to the point that i cant even push it to get it to fire anymore.. i visited the vaporium again the other day and there is someone who can fix it. Im going to have to meet this guy at the next vape meet! Ill keep this thread updated on the progress of it.
     
  7. Here is how I fixed mine today :D
    My Twist broke....
     
  8. Zooker

    Zooker Ultra Member Verified Member ECF Veteran

    Mar 30, 2012
    Washington State
    OMG I love this forum soooooooo much! Thank you! My husband broke his 2nd Twist today, I actually thought the button was gone...I just now went and pulled it out of the kitchen trash--eww it was on a wet coffee filter--I dried it all off and looked at it, and sure enough that button was jammed way inside. So I started smacking it against a notebook on the counter, and blammo, the button popped back out and it fires just fine! You just saved me $30 or whatever the 1000mah is going for these days, lol! Many thanks!
     
  9. edensin

    edensin Senior Member Verified Member ECF Veteran

    Apr 26, 2010
    Colleyville, TX
    You folks just might force me to get all techy yet. Thanks for the tutoral. :)
     
  10. X P3 Flight Engineer

    X P3 Flight Engineer Ultra Member Verified Member ECF Veteran

    Feb 27, 2012
    Moncton, N.B. Canada
    I have had a button press in and not come back. It has been dunked in salt water and also thrashed around on a lanyard during yard work, so I wasn't surprised. I pulled it apart and realigned the button and card and it works like new. Now That surprised me!

    BTW, if you have an old Star Dust laying around, they make a great "handle" to connect to a Twist or eGo when you want to pull them apart. Just remember to go slow and gentle so you don't pull the wires apart. Gently rock it up and down and side to side until it starts to move apart and then it takes very little pressure.

    I'm surprised and delighted at the use and abuse the Twist is able to take, especially for the price!
     
  11. Hunner

    Hunner Full Member Verified Member

    Sep 19, 2012
    Portland
    Thanks so much! I was able to fix my brothers too, with your pics.
     
  12. Hunner

    Hunner Full Member Verified Member

    Sep 19, 2012
    Portland
    Double post. Laggy internet >_<
     
  13. Thompson

    Thompson Ultra Member Verified Member ECF Veteran

    Apr 14, 2012
    North of NorCal
    This happened to me today, and I found another method of truly fixing the device

    With an old clearomizer (I had a Vision on there) you gently rock it back and forth, you'll notice the eGo 510 head will start to come out of the body. Just slowly work it until its all the way out. The pictures I took a moment ago will show better than I can describe. I thought they'd be glued or something, but its just a friction deal holding it all in there.

    [​IMG]
    [​IMG]

    Mine happened to have the wire break because of a separate incident. Originally I dropped it, the button lodged in sideways w/o the light on. Figured it was either 'junk it' or try and fix it.

    That top picture shows the newly soldered connection (as best I could do at 3am) and the bottom shows the wire broken off.

    Don't tug on anything too much, as it all seems very very gentle. Getting the button back into place is pretty simple. Put the button into the slot, align the button on the board to outside button and gently push back together.

    I also just thought seeing some of the internal components interesting :D
     
  14. smacuser

    smacuser Vapid Member Verified Member ECF Veteran

    Supporting member
    Jan 22, 2012
    Vape Augustine, FL
    I couldn't find my 1000 mah Twist this morning, but after looking all around, I found it under my bed. It looks just like Th3 FaT 0n3's pic. I had in on my dresser the night before and don't remember stepping on it. I can fire it with my finger nail on the bottom side like described by CappyCanuck.

    I will now go about trying to fix it by the suggestions posted and will post back with the results. Thanks guys.

    Later on: I successfully got it apart and found I broke off the black G wire and the plastic rectangle dish the button sits in had a corner broken off. Now I've rendered it useless. I don't have a solder gun or the patience of SteelJan, so off to LF. If I order today, I'll probably have a new one on Tuesday.
     
  15. subtle_banter

    subtle_banter Senior Member Verified Member ECF Veteran

    Jul 20, 2012
    Vermont
    I second the handle idea. I just screwed on a Kanger T2 and rocked it back and forth and opened it real easy. the button has a flat side. you want that side at the top. the back side of the button just sits on the clicky button underneath it, so it took a toothpick to slide the card back in and get it to sit right and keep the button in the hole....but, I did it! very proud of myself right now, I just saved $25! Hate to see these go to the waste basket..my buddy has already tossed 4 I could maybe have saved!
     
  16. awb777

    awb777 Full Member

    Oct 18, 2012
    South West Illinois
    Dropped mine today and the button got stuck in...I bashed it on my desk a few times to loosen the head. I worked the head out and just repositioned the button back in the hole, lined it up with the switch, and pressed the head back into place....Disaster averted! (of course this happened right after I put my other batt on the charger so...lol)
     
  17. Symmetry

    Symmetry Senior Member Verified Member ECF Veteran

    Nov 6, 2012
    Oregon, USA
    I've got this thread bookmarked in case it ever happens to me. Hopefully I'll be on an eVic soon so it won't matter, but I'm still keeping my Spinner as a backup...
     
  18. Bucky Goldstein

    Bucky Goldstein Senior Member Verified Member ECF Veteran

    The switch mechanism has just slipped out of alignment and the button is getting stuck in the opening
    if you tap it against a table either up, down or to the side (depending on which way it has moved) you can get it to line up again and work
     
  19. mecocina

    mecocina Super Member Verified Member ECF Veteran

    Feb 19, 2011
    Florida
    This just happened to me today. Watched videos to see if I can fix it but couldn't get the darn thing apart. Came back to ECF and wow...smacking it on a book worked. I had to do it a few times because the button straightened out but was flush with the collar. Saved me some $$, thanks!!
     
  20. Caridwen

    Caridwen ECF Moderator Senior Moderator Verified Member ECF Veteran

    Supporting member
    Jan 15, 2011
    Good thread. Maybe I should sticky it?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice