The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Innokin iTaste MVP in the House

Discussion in 'VV/VW APV Discussion' started by RPadTV, Nov 5, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Poeia

    Poeia Bird Brain Verified Member ECF Veteran

    http://.........blogspot.com/ finds good prices fairly regularly.

    I wasn't interested in the cartos so I bought the body, cord and cover at Health Cabin. Innokin is obviously controlling the price when even HC is charging basically the same thing but the co-op spends enough that we get 20% off plus a 5% coupon.
     
  2. dertbv

    dertbv Senior Member Verified Member ECF Veteran

    Nov 11, 2010
    Virginia
    Just wanted to swing in and give some thumbs up for the MVP.

    I bought my MVP in a coop a while back. It's primary purpose was a backup unit and the charging ability for my cell.
    I used it the first two days and put it away and forgot about it. Yesterday i was using my vamo and got the low ohms message. It was reading 1.1 and would not fire. Poped it on my MVP and it fired. I had a second atomizer that was reading 9.9 telling me that i had poped it. Figure what the hell and dropped it on the mvp and the dam thing fired. put it back on the vamo and read 9.9 again. thinking the vamu was giving me a bad reading tried another device that told me the atomizer is blown. put that sucker back on the MVP and dam if it is not firing it.

    Bottom line the MVP suprised me twice in a matter of a few minutes. Fired a 1.1 and a 9.9 without hesitation.

    Going to have to re-eveluate using it alot more.
     
  3. Scott_Simpson

    Scott_Simpson Ultra Member Verified Member ECF Veteran

    Jul 7, 2012
    Fort Wayne, IN
    A 9.9 represents an open circuit (e.g., no atomizer present, or a blown coil, etc.) ... the fact that your MVP would fire the device where the Vamo wouldn't indicates that the atomizer is not making contact at the 510 connection on the Vamo, whereas it is making connection on the MVP. It can't be a blown coil, since by definition there is no circuit (the coil wire is physically broken or burnt through, most likely, although a loose connection where the coil is fastened to the positive and negative posts is also possible), and nothing can fire an open circuit. I suspect that you need to pull the pin on your atomizer so that it makes contact with the Vamo's positive post ... it only needs to come out about a mm or less ...
     
  4. joeman

    joeman Senior Member ECF Veteran

    Mar 31, 2011
    Babson Park, Fla
    I need help. I bought a MVP for my son for Christmas and it didn't work after a week. Shipped back to vendor and they sent a new one. The 2nd just quit again!! My son did have a Crystal on it that had funky threading and I warned him not to screw his devices on too tight. After reading through threads I have learned a few things. A cleaning cycle? Didn't know that. I tried to raise the batt. connection to no avail. I then read that it may have detected a short or no connection so it may have shut down. I just wrote to him to have him turn it off and back on and put 1 of the iclears that came with it and hope that is what is the fix. Does anyone have anything to add??? Tia.
     
  5. t8kiteasy

    t8kiteasy Ultra Member Verified Member ECF Veteran

    Sep 22, 2012
    virginia beach
    Ask him to check and see if the output switch,on the bottom of the device,is set to OFF,while it's in use.He only needs to set it to ON,if he is charging something.
     
  6. joeman

    joeman Senior Member ECF Veteran

    Mar 31, 2011
    Babson Park, Fla
    T8, thanks for the reply. It is set to off. We have tried everything, I think!! This is the second one to just quit!! He tried last night to turn the unit off and back on to reset but no good?? Anyone else have this problem?
     
  7. t8kiteasy

    t8kiteasy Ultra Member Verified Member ECF Veteran

    Sep 22, 2012
    virginia beach
    There is only one other person here on this thread i remember having that problem.Can't remember who it was,but i do remember it being posted and i believe it had to do with where the usb plugs into the back,the pin has bent on it somehow.Someone else chime in if i am incorrect about that??
     
  8. Koman

    Koman Moved On ECF Veteran

    Jan 7, 2010
    lv
    Not sure, sounds like a very specific case!
     
  9. fisher

    fisher Senior Member ECF Veteran

    May 4, 2012
    Maryland
    So far so good with my Itaste. I have had it for two months and it still last for days at a time before recharging. One thing I did find was I had to set it .1 to .2 volts higher to achieve the same results as my ego twist. I think Busardo said something about it being how the chip and circuitry worked.
     
  10. Vaptor

    Vaptor Super Member ECF Veteran

    May 15, 2012
    sydney
    Seems to me that once my MVP hits the yellow light 1/2 battery charge, it just doesn't produce as well. Maybe the booster isn't as good as on other mods. Still, it is my most used mod. It does last me whole day in green and that's ok with me.
     
  11. KerryK

    KerryK Super Member ECF Veteran

    Sep 11, 2012
    Madtown, WI
    Camera(101).jpg

    Just got mine in a few days ago, I did press the center pin down too far, must have over tightened something. Just pulled the center pin back up a bit and it's working great. I agree with the upping the voltage for better results too, I found that to be the case for me as well.

    Running my Protanks around 4.5v
     
  12. Trik_Ster

    Trik_Ster Full Member

    Aug 12, 2010
    USA
    Hi
    I was an early adopter of the Innokin iTaste MVp
    The only clearomizer I've been able to get to work with it are the ones that shipped with it.
    I understand this problem was corrected with the Version 2 of the devices.

    Is there some adapter that corrects this problem?

    Or is there some kind of exchange program?

    I like the device but really need to be able to use other clearos with it

    TIA
    Trik_Ster
     
  13. TryinToQuit

    TryinToQuit Senior Member Verified Member ECF Veteran

    Dec 8, 2008
    ^This. Im having the same issue. VERY frustrating!! Cant get anything to work on it other than clone EVOD.
     
  14. Trik_Ster

    Trik_Ster Full Member

    Aug 12, 2010
    USA
    What is a clone EVOD?
    Is it the clearo that ships with the MVP?

    I emailed Innokin and got a reply stating that almost any clearo / atmo /carto will work with it, just don't use the beauty ring

    Emailed back sayin almost anything will thread onto the device but only the clearos it ships with will produce vapor
     
  15. LovinTheVapor

    LovinTheVapor Senior Member Verified Member ECF Veteran

    Jan 20, 2010
    Alpharetta, Ga
    No...the Clearo that ships with the MVP is a legitimate Innokin product.

    Here's an example of a EVOD clone:
    $2.65 EVOD Electronic Cigarette Round Mouth Atomizer (1.5mL) - orange / 2.4


    BTW my Kanger ProTank II works like a charm on my 1st Gen MVP
     
  16. Trik_Ster

    Trik_Ster Full Member

    Aug 12, 2010
    USA
  17. Dconnor

    Dconnor Ultra Member Verified Member ECF Veteran

    Sep 10, 2013
    Las Vegas
    I have the MVP2 and have useg the Kanger Pro II, mini pro II, evod and iclear 30 and all work great. The mini pro seems to work the best.
     
  18. tstar

    tstar Senior Member ECF Veteran

    Aug 21, 2013
    Philadelphia, PA, USA
    That sucks! I'm with the poster above me. I have used all my kanger products on the MVP 2 with no issue. Sticking with the Protank II though


    Sent from my iPhone using Tapatalk - now Free
     
  19. Trik_Ster

    Trik_Ster Full Member

    Aug 12, 2010
    USA
    Yeah there was a backlash when the MVP 1 came out and the MVP 2 was released very soon afterwards
    doesn't do me or the other early adopters any good though
     
  20. Capt.shay

    Capt.shay Vaping Master Verified Member ECF Veteran

    May 10, 2013
    W. Ma. U.S.A.
    I can't get a Kanger T-2 to work properly on my MVP 1 updated. They screw on but then you have to crack them back open a little to get a draw. I have tried several T-2's. I have and ego/510 adapter on the way that I hope will solve it.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice